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Introduction

Overview

Synology Deep Learning NVR features powerful Al Image Analysis technology, which is integrated
into the Deep Video Analytics application within Surveillance Station. Its complete functionality is
free of hidden fees and requires no extra software or external device installation.

The built-in GPU display card of Synology Deep Learning NVR leverages Deep Learning Al to
provide instant detection, tracking, and high-quality filtering of moving people in camera frames.
Upon detecting a moving object, Synology Deep Learning NVR will quickly run a calculation to
identify features of heads and shoulders and determine whether the object in action is human.
The counter increments when a person passes through and their head or body center crosses the
detection area.

Synology Deep Learning NVR models support multi-channel image analysis and can track and
trace multiple moving people simultaneously. For instance, the DVA3221 is capable of running
twelve People Counting analyses.

As unsuitable environments and settings may affect accuracy, the document will introduce the
key factors to successfully mounting and configuring cameras for optimal analytic accuracy. A
successful setup includes:

» Planning your installation
» Selecting suitable camera models and locations

» Configuring appropriate software settings

System requirements

« DVA series NAS with Surveillance Station version 9.0.2 or later

Mount Cameras

Big and clear images are the key to detection accuracy. A suitable mounting position and the right
environment can make a big difference in your results.

Select and position cameras

You can choose from between two different camera mounting types: ceiling mount and wall
mount.



General guidelines

Select a suitable camera mounting position for your environment. If the environment permits,
we recommend mounting the camera on the ceiling to prevent overlapping faces and to
increase the detection accuracy.

Select cameras that support multi-stream with 1920x1080 @20 FPS or above for a flexible
stream quality.

Do not use panoramic or fisheye cameras. Image distortion may influence the detection
results.

Keep the camera signal as stable as possible. Wired connections are highly recommended.
Keep the lenses clean so that dust, insects, or other stains do not block the view.

Keep passageways clear of traffic and ensure visitors do not linger around the detection area
to avoid multiple counts. Make sure moving objects such as automatic doors, escalators, and
cleaning robots are outside of the camera's view.



Ceiling mount positioning guidelines

For flexible stream quality, select ceiling-mounted cameras.

If your flooring reflects light or sharp shadows are cast on it, cover the detection area with a
mat or carpet.

Use flooring that contrasts with the hair color of your target visitors. For instance, use light
carpets for black hair and dark carpets for blonde hair.

Avoid complex patterns on the flooring to prevent interference with analysis.

Position your cameras directly above entrances, ensure they face straight down, and make
sure the footage contains complete shots of visitors' heads.
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» Mount cameras at least 2.5 to 4 meters (from floor to ceiling) above passageways. Depending
on camera models and zoom settings, the height range and covered ground can be increased.

- Human heads need to be complete to achieve high accuracy. If they always appear on the
edges of the screen, please adjust the camera height or use cameras with a larger angle of
view.
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» The heads of people smaller than 120 cm might be too small to be identified and may be
filtered out due to the on-screen head size settings. If you wish to reduce the on-screen head
size, keep in mind that this may increase the chance of interference from other small and
moving objects.

» People with hats, in costumes, holding umbrellas, or wearing accessories that cover their
heads might not be detected, or even affect the detection of others.

« People in motion should be kept in the middle of the camera frame for better precision.

« If the passageways are more than 4 meters wide, please set up two cameras to ensure that
the head images are complete and make sure the sizes do not vary too much.
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» The following table lists the recommended focal length and height values to cover a 4-meter

wide passageway:

Focal length (mm/ft) Height (m/ft)
2.8/0.082 3.0/9.85
4.0/013 4.0/131

Wall mount positioning guidelines

o Mount the cameras at least 2.5 to 4 meters high.



» Camera tilt angle should be less than 30 degrees.
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Detection Area

» Avoid having objects that block the camera's field of view such as pillars, barriers, fences,
gates, and trees.
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« Mount the camera as close as possible to the area of interest.

» Use the camera's optical zoom, if applicable.

Prepare suitable lighting

Good lighting is crucial. If the surroundings are too dark, footage may blur, and details may be
lost; if there is excessive illumination, images may be overexposed, and clarity may be affected. If
possible, please do the following:

» Provide sufficient lighting, preferably with a light level over 300 lux. Features of moving people
are hard to recognize in dark images.

» Avoid direct sunlight in the detection areas. Direct light may leave streaks in the images or
cause overexposure, affecting the picture quality.

« Do not point lights directly at the cameras; this may result in overexposed footage.



Camera night vision modes (IR modes) cannot compensate for insufficient light. Add
additional lighting if needed.

Remove flickering or glowing objects, such as neon lights.
Avoid uneven illumination. Movements in the darker areas might not be detected correctly.

Remove tilted light sources that create shadows, as shadows may blur the shape of human
features.

Adjust the color of the lighting according to the actual environment so that hair can be
separated from clothing. People may not be detected accurately if the color of their hair and
body are too similar.

Remove tilted light sources that create shadows as shadows may blur the shape of human
features.

Adjust the color of the lighting according to the actual environment so that hair can be
separated from clothing. People may not be detected accurately if the color of their hair and
body are too similar.

Note possible interferences

Even with meticulous planning of the camera mounting environment, human faces may be

misidentified or undetected. Please be aware that while interferences may cause miscalculations,

People Counting continues to function as intended.

Avoid irrelevant moving objects such as animals or vehicles.
People walking closely together might not be recognized correctly.
People moving too quickly past the camera might not be detected.

Weather sometimes affects the accuracy of outdoor cameras. Rain and snow, changes in
shadows, or differences between day and night are all possible interferences.

Configure Software Settings

Once your cameras have been successfully mounted, configure the software for DVA to meet your

needs.

This chapter covers the critical settings required for high People Counting precision. The following

diagram uses Ceiling Mount as an illustration.



Select your mount type

Add Deep Video Analytics Task

Select your setup

Select your camera mounting position. For hardware setup recommendations, see the

Ceiling mount wWall mount

Select a stream profile

For optimal detection accuracy, select a stream profile with a resolution of between 1920x1080
@20FPS and 3840x2160 (4K). Stream profiles are set by the Intelligent Video Analytics Recording
settings of the paired camera. To edit stream profiles, go to IP Camera and select the camera you
want to configure. Then click Edit > Edit > Recording > Stream > Intelligent Video Analytics
Recording to set the stream profile.

Note:

« To edit specific stream profile settings, go to IP Camera > select a camera > Edit >
Edit > Video & Audio Format > Video.

Define the detection line

People Counting will continuously track people's locations when they enter the camera view by
defining a midline to mark their heights. An event is triggered when 10% of the person's height



(measured from the bottom) exceeds the detection zone.

10%
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The detection line should be located on the ground, in the center of the camera screen, and span

the entire width of the passage. If the line is drawn too short, people might pass through the
entrance without crossing over it and be missed. The maximum length is 4 meters long.

Collect Footfall Data

After People Counting tasks are set up, you can start collecting and tracking footfall data. This
chapter introduces some helpful functions in People Counting.

Enable crowd detection

Crowd Detection can send event notifications and trigger alerts in Monitor Center when the
number of people in a given premises exceeds the set number. It is suitable for places where
footfall must be limited for safety concerns, such as stadiums and malls. Its headcount is highly
dynamic; the number is calculated by subtracting the number of people exiting from the number



of people entering.

Add Deep Video Analytics Task

Configure People Counting task settings

- Calculation Mode
Entering people count
Exiting people count
Entering/Exiting people count
Add the Crowd label to detection results automatically

Occupancy threshhold (entries minus exits): 100

- Counter Reset
Reset frequency:

Reset time:

Previous

Merge people counting tasks

The merge counting tasks function allows you to combine data from multiple counting tasks. For
example, if a building has three entry and exit points, each with its own counting task, merging
these tasks will give you the total count for the entire building.

To merge counting tasks, go to Deep Video Analytics > More > Merge counting tasks.



Deep Video Analytics
i= Task Add  Edit Enable ~  Delete

Detection Results Intrusion 2 - All Servers

Intrusion Detection Merge counting tasks Local Host

E Archive Settings Manage License Plate Database Joseph3221
. People counting
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Add Merge Counting Task

~ General

Merge

Local Host
Merge type: People Counting
Tasks: pc, People counting

Display information: Show All

» Global Settings

The following settings will be applied to the selected tasks.
Add the Crowd label to detection results automatically
When occupancy (entries minus exats) reaches:

Reset frequency: Daily

Reset time: 00

Generate Reports

After collecting footfall data, you can go to the Detection Results page to generate a People
Counting Report.
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Reports will list the number of people entering and exiting within a given date and time. With the
flexible display design, you can easily adjust the time range from daily to yearly. Data from
different tasks can also be shown simultaneously to accommodate spaces with multiple
entrances. If you wish to save a copy of the report, click Export to download it as an HTML or
Excel file.

Counting Report

Type

People Counting

Source

All tasks
Time range

Daily

12/17/2024

4 hours (unit)

Display

Bar Chart

All

Reset People Counter

By default the counter will reset daily at 00:00. The reset schedule can be changed to suit your
needs.



Add Deep Video Analytics Task

Configure People Counting task settings

A Calculation Mode
) Entering people count
) Exiting people count
Entering/Exiting people count
Add the Crowd label to detection results automatically

Occupancy threshhold (entries minus exits): 100

- Counter Reset
Reset frequency:

Reset time:

Previous




